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About

You can share this PDF with anyone you feel could benefit from it, downloaded the latest version 
from: notepadplusplus

It is an unofficial and free notepad++ ebook created for educational purposes. All the content is 
extracted from Stack Overflow Documentation, which is written by many hardworking individuals at 
Stack Overflow. It is neither affiliated with Stack Overflow nor official notepad++.

The content is released under Creative Commons BY-SA, and the list of contributors to each 
chapter are provided in the credits section at the end of this book. Images may be copyright of 
their respective owners unless otherwise specified. All trademarks and registered trademarks are 
the property of their respective company owners.

Use the content presented in this book at your own risk; it is not guaranteed to be correct nor 
accurate, please send your feedback and corrections to info@zzzprojects.com
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Chapter 1: Getting started with notepad++

Remarks

Notepad++ is a free (as in "free speech" and also as in "free beer") source code editor 
and Notepad replacement that supports several languages. Running in the MS 
Windows environment, its use is governed by GPL License. (Taken from official pages)

Notepad++ provides several advantages for developers. It's no huge Integrated Development 
Environment, it's just simply a light-weight text editor.

It provides

syntax highlighting for various programming languages•
strong Search/Replace feature using Regular expression and being able to process open 
files or given folders

•

line numbers•
auto-completion and parameters suggestion•
multi-editing•
macro recording and playing•
different style themes•
multiple execute commands•
many plugins to enhance the possibilities even further•

All these features convince various developers to use this editor.

Versions

Version Release Date

Version 7.3.3 2017-03-08

Version 7.3.2 2017-02-13

Version 7.3.1 2017-01-17

Version 7.3 2017-01-01

Version 7.2.2 2016-11-27

Version 7.2.1 2016-11-20

Version 7.2 2016-11-02

Version 7.1 2016-10-16

Version 7.0 2016-09-22
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https://notepad-plus-plus.org/download/v7.3.2.html
https://notepad-plus-plus.org/download/v7.3.1.html
https://notepad-plus-plus.org/download/v7.3.html
https://notepad-plus-plus.org/download/v7.2.2.html
https://notepad-plus-plus.org/download/v7.2.1.html
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Version Release Date

Version 6.9.2 2016-05-18

Version 6.9.1 2016-03-28

Version 6.9 2016-02-22

Version 6.8.8 2015-12-10

Version 6.8.7 2015-11-27

Version 6.8.6 2015-10-29

Version 6.8.5 2015-10-19

Version 6.8.4 2015-10-16

Version 6.8.3 2015-09-04

Version 6.8.2 2015-08-20

Version 6.8.1 2015-08-04

Version 6.8 2015-07-21

Version 6.7.5 2015-03-10

Version 6.7.4 2015-01-10

Version 6.7.3 2015-01-01

Version 6.7.2 2014-12-27

Version 6.7.1 2014-12-21

Version 6.7 2014-12-14

Version 6.6.9 2014-09-07

Version 6.6.8 2014-07-27

Version 6.6.7 2014-06-24

Version 6.6.6 2014-06-13

Version 6.6.4 2014-06-04

Version 6.6.3 2014-05-18

Version 6.6.2 2014-05-08
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https://notepad-plus-plus.org/download/v6.7.2.html
https://notepad-plus-plus.org/download/v6.7.1.html
https://notepad-plus-plus.org/download/v6.7.html
https://notepad-plus-plus.org/download/v6.6.9.html
https://notepad-plus-plus.org/download/v6.6.8.html
https://notepad-plus-plus.org/download/v6.6.7.html
https://notepad-plus-plus.org/download/v6.6.6.html
https://notepad-plus-plus.org/download/v6.6.4.html
https://notepad-plus-plus.org/download/v6.6.3.html
https://notepad-plus-plus.org/download/v6.6.2.html


Version Release Date

Version 6.6.1 2014-05-04

Version 6.6 2014-05-01

Version 6.5.5 2014-03-07

Version 6.5.4 2014-02-18

Version 6.5.3 2013-12-31

Version 6.5.2 2013-12-10

Version 6.5.1 2013-11-03

Version 6.5 2013-09-29

Version 6.4.5 2013-08-09

Version 6.4.4 2013-08-08

Version 6.4.3 2013-07-28

Version 6.4.2 2013-07-09

Version 6.4.1 2013-06-30

Version 6.4 2013-06-29

Version 6.3.3 2013-05-05

Version 6.3.2 2013-04-03

Version 6.3.1 2013-03-17

Version 6.3 2013-02-03

Version 6.2.3 2012-12-16

Version 6.2.2 2012-11-18

Version 6.2.1 2012-11-11

Version 6.2 2012-10-10

Version 6.1.8 2012-09-17

Version 6.1.7 2012-09-11

Version 6.1.6 2012-08-16
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Version Release Date

Version 6.1.5 2012-07-07

Version 6.1.4 2012-06-24

Version 6.1.3 2012-05-28

Version 6.1.2 2012-04-26

Version 6.1.1 2012-04-18

Version 6.1 2012-04-10

Version 6.0 2012-03-26

Version 5.9.8 2012-01-05

Version 5.9.6.2 2011-11-13

Version 5.9.6.1 2011-11-05

Version 5.9.6 2011-10-31

Version 5.9.5 2011-10-23

Version 5.9.4 2011-10-11

Version 5.9.3 2011-07-24

Version 5.9.2 2011-06-05

Version 5.9.0 2011-03-31

Version 5.8.7 2011-02-01

Version 5.8.6 2010-12-19

Version 5.8.5 2010-11-24

Version 5.8.4 2010-11-14

Version 5.8.3 2010-11-02

Version 5.8.2 2010-10-11

Version 5.8.1 2010-09-28

Version 5.8 2010-09-22

Version 5.7 2010-07-05
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Version Release Date

Version 5.6.8 2010-03-04

Version 5.6.7 2010-02-21

Version 5.6.6 2010-01-26

Version 5.6.5 2010-01-25

Version 5.6.4 2009-12-28

Version 5.6.3 2009-12-18

Version 5.6.2 2009-12-11

Version 5.6.1 2009-12-05

Version 5.6 2009-11-30

Version 5.5.1 2009-10-09

Version 5.5 2009-09-21

Version 5.4.5 2009-07-14

Version 5.4.4 2009-07-05

Version 5.4.3 2009-06-07

Version 5.4.2 2009-06-01

Version 5.4.1 2009-05-27

Version 5.4 2009-05-25

Version 5.3.1 2009-03-29

Version 5.3 2009-03-08

Version 5.2 2009-02-08

Version 5.1.4 2009-01-12

Version 5.1.3 2008-12-29

Version 5.1.2 2008-12-14

Version 5.1.1 2008-11-11

Version 5.1 2008-10-25
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Version Release Date

Version 5.0.3 2008-08-03

Version 5.0.2 2008-07-21

Version 5.0 2008-07-06

Version 4.9.2 2008-05-11

Version 4.9.1 2008-05-04

Version 4.9 2008-05-01

Version 4.8.5 2008-04-11

Version 4.8.2 2008-03-09

Version 4.8.1 2008-03-02

Version 4.7.5 2008-01-14

Version 4.7.3 2008-01-07

Version 4.7.2 2008-01-03

Version 4.7.1 2008-01-02

Version 4.6 2007-11-21

Version 4.5 2007-10-25

Version 4.4 2007-10-14

Version 4.3 2007-09-23

Version 4.2.2 2007-08-15

Version 4.1.2 2007-05-20

Version 4.1.1 2007-05-13

Version 4.1 2007-05-01

Version 4.0.2 2007-02-15

Version 4.0.1 2007-02-04

Version 4.0 2007-01-29

Version 3.9 2006-10-04
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Version Release Date

Version 3.8 2006-07-23

Version 3.7 2006-06-27

Version 3.6 2006-05-13

Version 3.5 2006-03-02

Version 3.4 2006-01-02

Version 3.3 2005-11-16

Version 3.2 2005-09-03

Version 3.1 2005-07-17

Version 3.0 2005-06-13

Version 2.9 2005-04-02

Version 2.8 2005-03-04

Version 2.7 2005-01-27

Version 2.6 2004-11-29

Version 2.4 2004-09-26

Version 2.3 2004-08-08

Version 2.2 2004-07-08

Version 2.1 2004-05-09

Version 2.0 2004-04-22

Version 1.9 2004-04-08

Version 1.8 2004-03-27

Version 1.7 2004-03-27

Version 1.6 2004-02-11

Version 1.5 2004-01-18

Version 1.4 2004-01-11

Version 1.3 2004-01-04
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Version Release Date

Version 1.2 2003-12-27

Version 1.1 2003-12-16

Version 1.0 2003-11-25

Examples

Installation or Setup

Notepad++ can be installed:

From the installer downloaded from the project's web site•
From Ninite, which would download and automatically install the latest version available: 
https://ninite.com/notepadplusplus/

•

Built from sources who are available in the GitHub Repo of this project.•

Read Getting started with notepad++ online: 
https://riptutorial.com/notepadplusplus/topic/2940/getting-started-with-notepadplusplus
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Chapter 2: Advanced Editing features

Examples

Multi-Editing

Multi-Editing allows the user to edit text at several locations simultaneously.

Multi-Editing is disabled by default: it can be enabled (resp. disabled) in Preferences > Editing by 
checking (resp. unchecking) the related checkbox.
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To use Multi-Editing, the user can Ctrl Click on the different locations and start to type.

During usage of Multi-Editing, text can be paste (e.g. by using Ctrl+V).

The user can also add some incremental numbers as follows:

Go to Edit > Column Mode (Alt+C)1. 
Select Number to insert2. 
Choose the starting number (e.g. 1), the increment (e.g. 1) and optionally a repeat number 
(e.g. 2 to have the following sequence 1 1 2 2 3 3 ...)

3. 

Column Editing

Column Editing enables the user to edit text on several lines as a vertical square zone.

This feature is enabled by default.

There are 3 ways to select a zone to edit:

Maintain Alt+Shift and use Up/Down/Left/Right to select the zone to edit with direction keys•
Maintain Alt+Shift and click on the document to define the other corner of the zone (the first 
corner being the position of the editing cursor)

•

Alt + select the zone to edit with the mouse while maintaining Click•
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To edit the text you can

Type the new text•
Paste•
Using Edit > Column Mode•

.

For example, to add some incremental numbers

Define a zone with the numbers to replace1. 
Edit > Column Mode > Number to insert and select the parameters2. 

Read Advanced Editing features online: 
https://riptutorial.com/notepadplusplus/topic/5047/advanced-editing-features
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Chapter 3: Auto-completion and suggestion

Examples

Basic settings of Auto-completion and suggestions

Notepad++ provides 2 types of features for auto-completion and suggestions:

Auto-completion that reads the open file and provide suggestion of words and/or functions 
within the file

•

Suggestion with the arguments of functions (specific to the language)•

To enable it, you need to change a setting.

Go to Settings > Preferences... > Auto-completion1. 
Check Enable Auto-completion on each input2. 
Select the type of completion you desire:

words only•
name of functions only•
both of them•

3. 

Optionally, check Function parameter hint on input to display parameters while typing a 
function name (c.f. picture below)

4. 

To use it, start to type a word or a function and after the number of characters you have specified, 
the suggestions will appear:
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Some documentation about auto-completion is available here: http://docs.notepad-plus-
plus.org/index.php/Auto_Completion

Customization of language suggestion (function parameter hint)

Parameters hints can be customized by the user as indicated in this link: http://docs.notepad-plus-
plus.org/index.php/Auto_Completion#How_to_create_keyword_auto-completion_definition_files

How to create keyword auto-completion definition files

Since version 5.0 Notepad++ has support for so called Calltips, and has introduced a 
new way of storing autocomplete data. Now everything is stored in the XML format, 
which allows for easy extension of functionality. By doing so, autocomplete and calltip 
data are combined in a single file. Older .api plain text files are no longer used by 
Notepad++, and can be safely deleted if present.

You can choose what srt of auto-completion you wish to have, from Settings -> 
Preferences -> Auto Completion -> Enable Auto-completion on each input: words from 
the current document, functions from the current language, or both.

The AutoComplete files are located in the "plugins\APIs" folder, to be found in the 
Notepad++ Install Folder, most often C:\Program Files\Notepad++.

The syntax of AutoComplete files is simple, but does have a few rules, most 
importantly correct syntax and proper sorting. If the syntax is incorrect, the XML file will 
fail to load and AutoComplete will be disabled. A more formal description can be found 
at Editing Auto-Completion files.

Improper sorting (see below) can cause the AutoComplete function to behave erratic, 
causing it to fail on certain words.

The basic character set used to recognise keywords is made of letters (i.e. a-z, A-Z, 0-9 
digits and the underscore). [...]

<?xml version="1.0" encoding="Windows-1252" ?> 
<NotepadPlus> 
   <AutoComplete language="C++"> 
       <Environment ignoreCase="no" startFunc="(" stopFunc=")" paramSeparator="," terminal=";" 
additionalWordChar = "."/> 
       <KeyWord name="abs" func="yes"> 
           <Overload retVal="int" descr="Returns absolute value of given integer"> 
               <Param name="int number" /> 
           </Overload> 
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       </KeyWord> 
   </AutoComplete> 
</NotepadPlus>

A small example of how the XML file is built is given above. NotepadPlus, 
AutoComplete and Environment are singleton elements, there should be only one of 
each, and all of them should be present for correctness, although it is allowed to 
remove the <Environment> element. Doing so will default all values to the ones given in 
the above example.

For keywords that are not functions, the Keyword tag is autoclosing and only has the 
name attribute. To indicate a keyword can be displayed in a calltip, add the attribute func 
with the value yes. In this case, the Keyword tag is a node and contains other tags.

Then, for each overload of the function, an Overload element should be added ,which 
specifies the behavior and the parameters of the function. A function must have at least 
one Overload or it will not be displayed as a calltip. The retVal attribute must be 
present and specifies the type of the return value, but the descr attribute is optional and 
describes the functions behavior, like a comment.

You can add newlines in the description if you wish to do so. For each parameter the 
function takes, a Param element can be added. The name attribute must be present and 
specifies the type of the parameters and/or any name of the parameter.

In the AutoComplete element you can add the language attribute but it is not used by 
Notepad++, you can add it for completeness if you wish and can take any string you 
want.

Read Auto-completion and suggestion online: 
https://riptutorial.com/notepadplusplus/topic/4843/auto-completion-and-suggestion
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Chapter 4: Regex

Examples

Referencing Capture Groups

Backreferences

"Backreferences" are references in a search regex to capture groups in the same search regex. 
The "search regex" is the regex used in the "Find" field of the Find/Replace dialog box. Here is the 
most common backreference syntax:

Absolute:  (group one)...\1 
 
Relative:  (group one)(group two)...\-1 
 
Named:     (?<name>group)...\k<name>

Substitutions

"Substitutions" are references in a replacement regex to capture groups in the associated search 
regex. The "replacement regex" is the regex used in the "Replace" field of the Find/Replace dialog 
box. Here is the most common substitution syntax:

Absolute:  $1 
 
Named:     $+{name}

More Than 9 Groups

The formats \1, \-1, and $n are limited single-digit numbers. In order to positionally reference a 
capture group greater than nine, use the following syntax instead:

Backreference:  (group one)...(group ten)...\g{10} 
 
Substitution:   ${10}

Capture Groups

A regex in Notepad++ may have as many capture groups as desired.

(one)(two)(three)...(nine)(more than nine groups!)...
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Anonymous capture groups use the standard syntax:

(group)

Named capture groups may use either of following syntax formats:

(?<name>group) 
 
(?'name'group)

Anonymous and named capture groups may be mixed in any order:

(anonymous)(?<name>named)(anonymous)

Capture groups are numbered starting from 1 based on the order of their opening parenthesis', 
regardless of nesting:

((group 2) group 1)

Note that named groups are included in the numbering:

(group 1)(?<name>group 2)(group 3)

Read Regex online: https://riptutorial.com/notepadplusplus/topic/8714/regex
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Chapter 5: Useful plugins for developers

Examples

NppExec

NppExec [sourceforge] allows you to execute commands and scripts from a console window in 
Notepad++. It can be found in the menu bar at Plugins -> NppExec or just by simply hitting the F6 
key (the shortcut Ctrl+F6 will run the latest command) .

Example: the following will

Set the console to output_var: on, meaning we can use the output of the console•
run a SQL query from the file C:\scripts\query.sql•
take the output from the console and put it into the active file at the cursor•
close the console•
clear the console•

NPE_CONSOLE v+ 
sqlcmd -S 111.111.1.1 -U UserName -P "password" -i C:\scripts\query.sql 
sel_settext $(OUTPUT) 
NPP_CONSOLE 0 
cls

NppExec also allows you to save your scripts. After saving them, you can go to Plugins -> NppExec 
-> Advanced Options and run it anytime Notepad++ starts, closes, or even add that script to the 
Plugin commands using Macros. For example, by saving the above example as a "Run Query", I 
could use the bottom left fields in the Advanced Options to add it to the menu.

The script will be available as a macro after a restart of Notepad++ as long as the "Place to the 
Macros submenu" box is checked.
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Finally, a shortcut can be assigned to the macro/command by using Settings -> Shortcut mapper 
-> Plugin commands.

TextFX

TextFX [SourceForge] is plugin for advanced character conversions (escaping characters etc.) 
and code formatting (HTML or C++ code).

JSON Viewer

JSON Viewer SourceForge is a plugin for JSON visualization and formatting. It is useful for 
indenting /formatting JSON documents and can be used to browse complex JSON file using a 
treeview tool.

The following image shows the commands offered by the plugin:

Starting from an unformatted JSON fragment (Example from http://www.json.org ):

{"glossary": {"title": "example glossary","GlossDiv": {"title": "S","GlossList": 
{"GlossEntry": {"ID": "SGML","SortAs": "SGML","GlossTerm": "Standard Generalized 
Markup Language","Acronym": "SGML","Abbrev": "ISO 8879:1986","GlossDef": {"para": 
"A meta-markup language, used to create markup languages such as 
DocBook.","GlossSeeAlso": ["GML", "XML"]},"GlossSee": "markup"}}}}}

To format and indent the code:

select all the json fragment•
click "Plugins"/"JSON Viewer"/"Format JSON" or use the shortcut Ctrl + Alt + Shift + M•

This is the resulting formatted code:
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The plugin can also show a treeview browsable version of the JSON fragment:

select all the json fragment•
click "Plugins"/"JSON Viewer"/"Show JSON Viewer" or use the shortcut Ctrl + Alt + Shift + J•

The following screenshot shows how the plugin renders the JSON structure:
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SourceCookifier

SourceCookifier parses the current source code for such components as class, function, and 
variable names and displays them in a tree view at a side panel. Navigation among these 
members is possible by double-clicking on the component name. The plugin supports a number of 
languages and customizations are possible for undetermined or user-defined languages. This is 
useful when working with large codes.
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By default, SourceCookifier session mode is set to Single file mode. Other available modes are 
N++ session mode (all the files open in Notepad++) or Cookie session mode.

To use Cookie session mode:

Drag & Drop your folders with source code to Source Cookifier window1. 

Select the type of files you want to parse2. 
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Notes:

You can save and load the cookie sessions; moreover, Source Cookifier display the history 
of the latest sessions

•

Opening the file of a saved session in Notepad++ will automatically switch SourceCookifier 
into cookie session mode and load this session

•

Maintaining a keyboard modifier (CTRL, SHIFT, or ALT - they are all similar) while drag-dropping 
the folder will fasten the parsing by only adding INCLUDES and not tags

•

Another useful feature is the ability to jump to the definition of a symbol (e.g. function)

Select the right "session mode": use cookie mode if the definition of the symbol is in another 
file not opened in Notepadd++, or single file mode if the definition is in the same file

1. 

In Notepad++, put the cursor in the function/type you want to get definition of, and press CTRL
+SHIFT+ENTER to jump to the definition. If there are several definitions, you can choose the file 
you want to open

2. 
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You can press ALT+LEFT to come back to the previous location (and ALT+RIGHT to go back to 
the definition)

3. 

Read Useful plugins for developers online: 
https://riptutorial.com/notepadplusplus/topic/3677/useful-plugins-for-developers
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