scikit-learn Installazione di scikit-learn


Esempio

L'attuale versione stabile di scikit-learn richiede :

  • Python (> = 2.6 o> = 3.3),
  • NumPy (> = 1.6.1),
  • SciPy (> = 0,9).

Per la maggior parte di installazione pip gestore di pacchetti python può installare python e tutte le sue dipendenze:

pip install scikit-learn

Tuttavia, per i sistemi Linux si consiglia di utilizzare il gestore pacchetti conda per evitare possibili processi di compilazione

conda install scikit-learn

Per verificare di avere scikit-learn , esegui in shell:

python -c 'import sklearn; print(sklearn.__version__)'

Installazione di Windows e Mac OSX:

Canopy e Anaconda hanno entrambi una versione recente di scikit-learn , oltre a un ampio set di librerie scientifiche Python per Windows, Mac OSX (anche per Linux).