tensorflow Installazione o configurazione


Esempio

A partire da Tensorflow, l'installazione della versione 1.0 è diventata molto più facile da eseguire. Come minimo, per installare TensorFlow occorre un pip installato sulla propria macchina con una versione python di almeno 2.7 o 3.3+.

pip install --upgrade tensorflow      # for Python 2.7
pip3 install --upgrade tensorflow     # for Python 3.n

Per tensorflow su una macchina GPU (a partire da 1.0 richiede CUDA 8.0 e cudnn 5.1, GPU AMD non supportata)

pip install --upgrade tensorflow-gpu  # for Python 2.7 and GPU
pip3 install --upgrade tensorflow-gpu # for Python 3.n and GPU

Per verificare se ha funzionato, apri la versione corretta di python 2 o 3 ed esegui

import tensorflow

Se ciò è riuscito senza errori, hai installato tensorflow sul tuo computer.



* Siate consapevoli che questo riferimento al ramo principale si può cambiare questo sul link qui sopra per fare riferimento alla versione stabile corrente.)