Looking for guava Answers? Try Ask4KnowledgeBase
Looking for guava Keywords? Try Ask4Keywords

guavaEmpezando con la guayaba


Observaciones

Esta sección proporciona una descripción general de qué es la guayaba y por qué un desarrollador puede querer usarla.

También debe mencionar cualquier tema importante dentro de la guayaba y vincular a los temas relacionados. Dado que la Documentación para guayaba es nueva, es posible que deba crear versiones iniciales de esos temas relacionados.

Versiones

Versión Fecha de lanzamiento
r01% 2009-09-15
r02 2010-01-04
r03 2010-04-09
r04 2010-04-27
r05 2010-05-28
r06 2010-07-07
7.0 2010-09-22
8.0 2011-01-27
9.0 2011-04-07
10.0 2011-09-28
11.0 2011-12-18
12.0 2012-04-30
13.0 2012-08-03
14.0 2013-02-25
15.0 2013-09-06
16.0 2014-01-17
17.0 2014-04-22
18.0 2014-08-25
19.0 2015-12-09

% no incluyó Google Collections, que existía por separado en ese momento

Nota: Las versiones 1.0 a 11.0 requieren JDK 1.5 o más reciente. Las versiones 12.0 a 20.0 requieren JDK 1.6 o más reciente. Se espera que la versión 21.0 requiera JDK 1.8 o más reciente.

Preparar

La dependencia de la guayaba se puede agregar a su proyecto Java utilizando cualquier sistema de compilación.

Maven

<dependency>
  <groupId>com.google.guava</groupId>
  <artifactId>guava</artifactId>
  <version>19.0</version>
</dependency>
 

Gradle:

dependencies {
  compile 'com.google.guava:guava:19.0'
}
 

Hiedra

<dependency org="com.google.guava" name="guava" rev="19.0" />
 

Construir

compile.with 'com.google.guava:guava:jar:19.0'
 

Dependencia manual

También puedes descargar JARs manualmente desde la página de lanzamiento de Guava para las clases, fuentes y javadocs.

Tenga en cuenta que para Guava 12.0 a 20.0 se requiere JDK 1.6 o posterior. Ver la lista de versiones para más información. Los usuarios de Guayaba que se dirigen a Java 5 deben usar el puerto trasero Guava JDK5 . Esto incluye a los usuarios que se dirigen a Android Froyo y anteriores.