firebirdDémarrer avec Firebird


Remarques

Firebird ( ) est un système de gestion de base de données relationnelle open source (SGBDR). Il est open source et gratuit . Il est puissant et facile à gérer.

Firebird fonctionne sur différents systèmes. Par exemple, Firebird 2.5 fonctionne sous Windows (32 et 64 bits), différentes versions de Linux (32 et 64 bits), Solaris (Sparc et Intel), HP-UX (PA-RISC) et MacOS X.

Versions

Version Marque Date de sortie
3.1 2016-09-27
3.0 2016-04-19
2,5 2010-10-04
2.1 2008-04-18
2.0 2006-11-12
1,5 2004-02-20
1.0 2002-03-12

Installation ou configuration

Télécharger

Utilisez le site Firebird pour télécharger le " package de serveur " correct pour votre système. Tout d'abord, sélectionnez la version de Firebird que vous souhaitez installer. Ensuite, sélectionnez le programme d'installation approprié pour votre système. Par exemple, pour presque toutes les versions de Windows 32 bits, vous devez sélectionner sous les kits 32 bits l'option "Programme d'installation exécutable Windows recommandé pour les nouveaux utilisateurs".

Installation

Exécutez le programme d'installation et suivez les instructions. Pour les nouveaux utilisateurs, vous n'aurez probablement pas besoin de modifier la configuration du programme d'installation.

Quelle est la version d'ODS et comment la récupérer?

La version d'ODS (structure sur disque) est un numéro représentant la version de la structure de mise en forme de données de bas niveau de la base de données. Lorsqu'une nouvelle fonctionnalité est ajoutée à Firebird, elle peut nécessiter ou non la structure des pages de base de données ou des tables système (métadonnées de base de données). Si c'est le cas, la version d'ODS doit augmenter.

Ce nombre est vérifié lors de la connexion, de sorte que le serveur s'assure qu'il peut «comprendre» la structure de la base de données. Par exemple, lorsque vous essayez de vous connecter avec un serveur 1.0 à une base de données créée avec Firebird 2.0, vous obtenez une erreur car le serveur 1.0 n'est pas capable de gérer cette ODS - simplement parce qu'il y a des champs qu'il ne comprend pas.

Firebird 2.5 peut ouvrir des bases de données avec ODS de Interbase 5, Interbase 6 et Firebird 0.9 à 2.5. Cependant, Firebird 3.0 était un bon début en matière de compatibilité ascendante et il ne peut plus ouvrir de bases de données avec les versions ODS des versions précédentes de Firebird.

La version d'ODS, telle que rapportée par les outils utilisateur, montre avec quelle version de serveur la base de données a été créée, par exemple:

-------------------------------------------------------------
Database created with version:                    ODS version:
InterBase® 5                                                9
InterBase® 5.5, 5.6                                        9.1
InterBase® 6    /   Firebird 1.0                          10.0
InterBase® 6.5  /   Firebird 1.5                          10.1
InterBase® 7    /   Firebird 2.0                            11
InterBase® 7.1  /   Firebird 2.1                          11.1
InterBase® 7.5  /   Firebird 2.5                          11.2
InterBase® 2007 /   Firebird 3.0                            12
InterBase® 2009                                             13
InterBase® XE                                             15.0
 

NOTE 1: Lorsque la même version d'ODS a été signalée pour certaines versions d'Interbase et de Firebird, ce qui ne signifie PAS que l'ODS est identique, cela ne signifie PAS la compatibilité entre les limites de l'IB / FB! Sauf pour Firebird 0.9 et 1.0 et Interbase 6.0 qui étaient presque compatibles. À l'époque, on s'attendait à ce qu'Interbase soit conservé opensource et réutilise le code du projet Firebird. Cependant, avec Interbase 6.5, il a été modifié. Ce que cela signifie pratiquement ici, c'est que, même si certaines bases de données Interbase / Yaffil / Firebird peuvent indiquer qu'elles ont la même version ODS (nombre), leur structure même devenait de plus en plus différente. IB 7 n'ouvrirait pas la base de données FB 2 et vice versa - ils ont différents formats internes (ODS), alors que les deux projets désormais séparés leur donnaient le même numéro de version. La version d'ODS peut être la même entre certaines versions d'IB et de FB, mais l'ODS lui-même (à l'exception de l'IB6.0) ne le serait pas!

NOTE 2: avec la version 1.5 de Firebird, une version 64 bits du serveur a été introduite. Les bases de données créées avec des versions 64 bits et 32 ​​bits de Firebird 1.5 signalent toutes deux la version 10.1 d'ODS, mais leurs ODS réels sont un peu différents et ils ne peuvent pas ouvrir les bases de données les uns des autres. À partir de FB 2.0, qui a été corrigé et que les versions x86 et x64 de Firebird Server peuvent ouvrir des bases de données créées les unes par les autres.

Pour récupérer la version d'ODS, vous pouvez utiliser l'API Firebird ou simplement utiliser l'outil qui le lit pour vous.

Si vous ne disposez que d'un accès en ligne de commande, vous pouvez utiliser l'outil de ligne de commande gstat de Firebird (situé dans le répertoire bin). Son option -h renvoie les informations de la page d'en-tête, qui contient l'ODS:

gstat –h database_file_name
 

Utilisateur et mot de passe inutiles, car gstat avec l'option –h lit simplement la partie physique de la base de données (page d'en-tête, numéro 0).

Si gstat ne comprend pas les informations lues, il affichera le message correspondant - ce à quoi il s’attend et ce qu’il a trouvé.

Si vous ne disposez que d'une connexion distante au serveur et que vous pouvez vous connecter à la base de données, vous ne pouvez accéder au fichier de base de données, mais à partir de Firebird 2.1, vous pouvez également interroger ODS à l'aide de commandes SQL régulières.

     select MON$ODS_MAJOR, MON$ODS_MINOR from MON$DATABASE
 

Exemple d'invite de commande:

entrer la description de l'image ici

Exemple d'utilisation "Database Properties" dans:

FlameRobin :

entrer la description de l'image ici

IbExpert:

entrer la description de l'image ici