spring-data-jpa开始使用spring-data-jpa


备注

本节概述了spring-data-jpa是什么,以及开发人员可能想要使用它的原因。

它还应该提到spring-data-jpa中的任何大型主题,并链接到相关主题。由于spring-data-jpa的文档是新的,您可能需要创建这些相关主题的初始版本。

版本

发布日期
1.9.0.RELEASE 2015年9月1日
1.8.0.RELEASE 2015年3月23日
1.7.0.RELEASE 2014年9月5日
1.6.0.RELEASE 二零一四年五月二十零日
1.5.0.RELEASE 2014年2月24日
1.4.0.RELEASE 2013年9月9日
1.3.0.RELEASE 2012-02-07
1.2.0.RELEASE 2012年10月10日
1.1.0.RELEASE 2012-05-16
1.0.0.RELEASE 2011-07-21

按实体属性搜索并按实体属性搜索

WarehosueEntity findWarehouseById(@Param("id") Long id);

List<WarehouseEntity> findWarehouseByIdIn(@Param("idList") List<Long> warehouseIdList);
 

安装或设置

要开始使用Spring数据JPA,您必须将Spring中的依赖项一起包含在项目中。如果您使用Maven作为依赖关系管理系统(替换您要使用的版本的版本号 ):

<dependencies>
    <dependency>
        <groupId>org.springframework.data</groupId>
        <artifactId>spring-data-jpa</artifactId>
        <version>version-number</version>
    </dependency>
</dependencies>
 

如果你正在使用Gradle:

dependencies {
    compile 'org.springframework.data:spring-data-jpa:version-number'
}
 

您还可以在使用Spring Boot时进行设置,只需包含启动器依赖项并删除版本号:

<dependencies>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-data-jpa</artifactId>
    </dependency>
</dependencies>