tfs2015Aan de slag met tfs2015


Opmerkingen

Deze sectie biedt een overzicht van wat tfs2015 is en waarom een ontwikkelaar het misschien wil gebruiken.

Het moet ook alle grote onderwerpen binnen tfs2015 vermelden en naar de gerelateerde onderwerpen verwijzen. Aangezien de documentatie voor tfs2015 nieuw is, moet u mogelijk eerste versies van die gerelateerde onderwerpen maken.

Vereisten voor Team Foundation Server 2015

Team Foundation Server (TFS) kan op twee basisinfrastructuurmanieren worden geïnstalleerd, Single Server Deployment en Multi-Server Deployment. Het verschil tussen deze twee implementaties is waar de Application Tier (TFS) en de Data Tier (MS SQL) zich bevinden.

Het wordt als beste praktijk beschouwd om TFS te installeren in een implementatie met meerdere servers.

Voordat u TFS 2015 kunt installeren, moet u ervoor zorgen dat u aan de vereisten voor zowel hardware als software hebt voldaan.

Volgens Microsoft Documentation ondersteunt TFS 2015 32-bit hardware, maar het wordt sterk aanbevolen om op 64-bit te installeren, aangezien TFS 2017 ALLEEN 64-bit ondersteunt.

Implementatie van één server:

  • 1 dual-core processor
  • 4 tot 8 GB RAM

Implementatie van meerdere servers:

  • Toepassingsniveau
    • 1 dual-core processor
    • 8 tot 16 GB RAM (of meer)
    • Hoogwaardige opslag zoals een SSD
  • Gegevenslaag
    • 1-2 Quad-Core-processor
    • 8 tot 16 GB RAM (of meer)
    • Hoogwaardige opslag zoals een SSD

Ondersteuning voor besturingssysteemversie:

  • Windows Server 2016
  • Windows Server 2012 R2 (Essentials, Standard, Datacenter)
  • Windows Server 2012 (Essentials, Standard, Datacenter)
  • Windows Server 2008 R2 (minimaal SP1) (Standard, Enterprise, Datacenter)

Ondersteuning voor Microsoft SQL Server-versies:

TFS ondersteunt Express-, Standard- en Enterprise-edities, maar het wordt aanbevolen om Standard als het absolute minimum te gebruiken.

  • TFS 2015 Update 3
    • SQL Server 2016
    • SQL Server 2014
    • SQL Server 2012 ( minimaal SP1 )
  • TFS 2015 ( aanbevelen dat u zo snel mogelijk update 3 krijgt )
    • SQL Server 2014
    • SQL Server 2012 (minimaal SP1)

De volgende benodigde componenten van Microsoft SQL zijn nodig:

  • Vereist voor TFS
    • Database Engine Services
    • Volledige tekst en semantische extracties voor zoeken
  • Vereist voor rapportage
    • Reporting Services - native
    • Analysediensten

Ondersteuning voor Microsoft SharePoint-versies:

  • SharePoint 2013 (Foundation, Standard, Enterprise)
  • SharePoint 2010 (Foundation, Standard, Enterprise)