solr Apache Solr Solr installation


Example

You can install Solr in any system where a suitable Java Runtime Environment (JRE) is available, as detailed below. Currently this includes Linux, OS X, and Microsoft Windows. You will need the Java Runtime Environment (JRE) version 1.8 or higher. At a command line, check your Java version like this:

$ java -version

Solr is available from the Solr website at http://lucene.apache.org/solr/. Extract the Solr distribution archive to your local directory