Looking for php Keywords? Try Ask4Keywords

PHPMulti-Threading-Erweiterung


Bemerkungen

Mit pthreads v3 können pthreads nur mit dem cli SAPI geladen werden. Daher empfiehlt es sich, die Direktive extension=pthreads.so NUR in php-cli.ini , wenn Sie PHP7 und Pthreads v3 verwenden.

Wenn Sie Wamp unter Windows verwenden , müssen Sie die Erweiterung in php.ini konfigurieren :

Öffnen Sie php \ php.ini und fügen Sie Folgendes hinzu:

extension=php_pthreads.dll

In Bezug auf Linux- Benutzer müssen Sie .dll durch .so ersetzen:

extension=pthreads.so

Sie können diesen Befehl direkt ausführen, um ihn der php.ini (ändern Sie /etc/php.ini mit Ihrem benutzerdefinierten Pfad).

echo "extension=pthreads.so" >> /etc/php.ini

Multi-Threading-Erweiterung Verwandte Beispiele