PHPMulti Threading Extension


Osservazioni

Con pthreads v3 i pthreads possono essere caricati solo quando si usa il cli SAPI, quindi è buona norma mantenere l' extension=pthreads.so direttiva in php-cli.ini SOLO, se si utilizza PHP7 e Pthreads v3.

Se si utilizza Wamp su Windows , è necessario configurare l'estensione in php.ini :

Apri php \ php.ini e aggiungi:

extension=php_pthreads.dll

Per quanto riguarda gli utenti di Linux , devi sostituire .dll di .so :

extension=pthreads.so

Puoi eseguire direttamente questo comando per aggiungerlo a php.ini (cambia /etc/php.ini con il tuo percorso personalizzato)

echo "extension=pthreads.so" >> /etc/php.ini

Multi Threading Extension Esempi correlati