Laravel Requirements


Example

The Laravel framework has the following requirements:

5.3
  • PHP >= 5.6.4
  • XML PHP Extension
  • PDO PHP Extension
  • OpenSSL PHP Extension
  • Mbstring PHP Extension
  • Tokenizer PHP Extension
5.1 (LTS)5.2
  • PHP >= 5.5.9
  • PDO PHP Extension
  • Laravel 5.1 is the first version of Laravel to support PHP 7.0.
5.0
  • PHP >= 5.4, PHP < 7
  • OpenSSL PHP Extension
  • Tokenizer PHP Extension
  • Mbstring PHP Extension
  • JSON PHP extension (only on PHP 5.5)
4.2
  • PHP >= 5.4
  • Mbstring PHP Extension
  • JSON PHP extension (only on PHP 5.5)